NexentaStor 3.0.0-6 / iSCSI Target (Comstor) not working with VMWare 4

Added by Jefferson Nunn over 4 years ago

I have NexentaStor 3.0.06 on a stand alone (not vmwared) box with 4x 1tb drives.

I am trying to publish iSCSI from this to a VMWare box (ESXi 4.0.0 208167).

The UserGuide included with the NexentaStor is version 2.2. The directions provided do work with the version 2.2 product for publishing the ZFS volume via iSCSI.

The directions provided do not work with version 3.0 since there are several screens different or missing. Below are screenshots:

Nexenta 2.2 Target Portal Groups - http://imgur.com/ae6Dp.jpg

Nexenta 2.2 ZVol Sharing settings - http://imgur.com/StZvK.jpg

Nexenta 2.2 Zvol params - note the section at the bottom ... This doesn't exist in 3.0 - http://imgur.com/reXBD.jpg

Nexenta 3.0 IScsi Target Settings - http://imgur.com/WzTuP.jpg

Nexenta 3.0 IScsi Portal Group - http://imgur.com/v7jvC.jpg

Nexenta 3.0 ZVol Sharing settings (Details) - http://imgur.com/gl8sT.jpg

Nexenta 3.0 Zvol main sharing area - http://imgur.com/qn52t.jpg

In short, even though my ZVol is shared and I have a Target Portal Group set and there are target settings, using Dynamic Discovery or Static Discovery on my VMWare box I cannot see the newly created volume from 3.0 but the volume from 2.2 is there.

VMWare iSCSI settings - http://imgur.com/MmO2V.jpg

VMWare results - http://imgur.com/qWBNT.jpg

I apologize for not being able to make links using IMG tags. The Wiki editor doesn't permit it and I can't seem to make the URL links to work.


Replies

RE: NexentaStor 3.0.0-6 / iSCSI Target (Comstor) not working with VMWare 4 - Added by Dmitry Yusupov over 4 years ago

You can find SCSI Target 3.0 documentation here:

http://www.nexenta.com/corp/documentation/product-documentation

Documentation is being updated, not yet fully completed. Just keep in mind that advanced Enterprise level LU mappings are not available in CE.

RE: NexentaStor 3.0.0-6 / iSCSI Target (Comstor) not working with VMWare 4 - Added by Jefferson Nunn over 4 years ago

Thanks for the reply. After reading the document, I found something on the CLI that had to be done to publish the ISCSI Target:

setup iscsi target arrow over to iqn enter 4 times

Not sure how to do this on the GUI but this fixed it.

Thanks!

Content-Type: text/html; charset=utf-8 Set-Cookie: _redmine_session=BAh7BiIKZmxhc2hJQzonQWN0aW9uQ29udHJvbGxlcjo6Rmxhc2g6OkZsYXNoSGFzaHsABjoKQHVzZWR7AA%3D%3D--cebfb08d300a85bd88dafd1422210ebe7c9a5873; path=/; HttpOnly Status: 500 Internal Server Error X-Powered-By: Phusion Passenger (mod_rails/mod_rack) 2.0.3 ETag: "5be3bf35f7a7a64d14f51085b55b10dd" X-Runtime: 481ms Content-Length: 9036 Cache-Control: private, max-age=0, must-revalidate redMine 500 error

Internal error

An error occurred on the page you were trying to access.
If you continue to experience problems please contact your redMine administrator for assistance.

Back